Web Forms For Marketer MVC – Blank Sitecore Tree When Displaying FormID in Presentation Details

So – a lovely short post this one. It seems there is a slight issue in templates in the first generation MVC release of Sitecore Web Forms For Marketers (2.4)

After installing WFFM for MVC 2.4, I noticed that the FormID rendering parameter on the MVC Form rendering is incorrectly pointing at the Sitecore Tree root. I was expecting this to point at a forms folder. I don’t know if this behaviour is displayed on other versions of Sitecore – I am on 7.2 update 1 at present.

On further investigation, it appears that there is a typo in the Data Source in the rendering parameters template declaration. To fix it on mine I simply needed to follow these steps.

  1. Navigate to the template => /sitecore/templates/Web Forms for Marketers/Renderings/Interpreter Properties (ID – {2816D841-7573-4080-9418-80BAC327A539})
  2. The data source was (on my instance at least) set to: Source={D81AC026-07B6-4929-9588-40ACBDC56435}
  3. Simply Change it to: DataSource={D81AC026-07B6-4929-9588-40ACBDC56435} or {D81AC026-07B6-4929-9588-40ACBDC56435}

(On my machine at least) VOILA, problem solved 😀

Glad it’s not just me that releases code with typo’s, it happens to the best of us 😉

Hope this helps.

Advertisements

2 thoughts on “Web Forms For Marketer MVC – Blank Sitecore Tree When Displaying FormID in Presentation Details

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s